summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2022-01-21 19:42:26 -0500
committerOleg Pykhalov <go.wigust@gmail.com>2022-01-22 12:07:55 +0300
commitd0744d8650b9b5358f19b94a1f886f029f3d3f78 (patch)
tree382a8bb2b15fc1b5fe76909439144d5effdd248a
parentc8512d84438b91e636231dbc2f111051473f4609 (diff)
downloadguix-patches-d0744d8650b9b5358f19b94a1f886f029f3d3f78.tar
guix-patches-d0744d8650b9b5358f19b94a1f886f029f3d3f78.tar.gz
gnu: jacal: Update to 1c7.
* gnu/packages/patches/jacal-fix-texinfo.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Delete this. * gnu/packages/maths.scm (jacal)[source]: Delete this patch. [version]: Update to 1c7. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/maths.scm9
-rw-r--r--gnu/packages/patches/jacal-fix-texinfo.patch92
3 files changed, 4 insertions, 98 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 01908feb0d..04ff0fc94b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1298,7 +1298,6 @@ dist_patch_DATA = \
%D%/packages/patches/json-c-0.13-CVE-2020-12762.patch \
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
%D%/packages/patches/jsoncpp-pkg-config-version.patch \
- %D%/packages/patches/jacal-fix-texinfo.patch \
%D%/packages/patches/jami-fix-crash-on-quit.patch \
%D%/packages/patches/jamvm-1.5.1-aarch64-support.patch \
%D%/packages/patches/jamvm-1.5.1-armv7-support.patch \
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f9dd62a32d..9a0f913c5a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5789,15 +5789,14 @@ Longest Commons Subsequence of a set of strings.")
(define-public jacal
(package
(name "jacal")
- (version "1c4")
+ (version "1c7")
(source (origin
(method url-fetch)
(uri (string-append
"http://groups.csail.mit.edu/mac/ftpdir/scm/jacal-"
version ".zip"))
- (sha256 (base32
- "055zrn12a1dmy0dqkwrkq3fklbhg3yir6vn0lacp4mvbg8573a3q"))
- (patches (search-patches "jacal-fix-texinfo.patch"))))
+ (sha256
+ (base32 "06a5sx9ikd62bpnd898g3yk818b020b1a27mk7dbfla2zizib4xz"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -5823,7 +5822,7 @@ Longest Commons Subsequence of a set of strings.")
(chmod wrapper #o555))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
- (invoke "./configure"
+ (invoke "sh" "configure"
(string-append "--prefix="
(assoc-ref outputs "out"))))))))
(inputs (list scm))
diff --git a/gnu/packages/patches/jacal-fix-texinfo.patch b/gnu/packages/patches/jacal-fix-texinfo.patch
deleted file mode 100644
index 83e44a3164..0000000000
--- a/gnu/packages/patches/jacal-fix-texinfo.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-Fix the broken Texinfo in the Jacal package documentation
-
---- jacal/jacal.texi,orig 2017-02-23 20:35:55.303980444 +0100
-+++ jacal/jacal.texi 2017-02-23 20:53:14.539024674 +0100
-@@ -343,7 +343,7 @@
-
- With the standard input grammar, the precedence of @samp{-} as a prefix
- behaves strangely. @code{a^-b*c} becomes @code{a^(-b*c)} while
--@code{@result{a^b*c} (a^b)*c}.
-+@code{a^b*c @result{} (a^b)*c}.
-
- Using @code{divide} to divide a polynomial by an integer does not work.
-
-@@ -675,8 +675,9 @@
- e1: ---------
- a
- @end example
-+@end deffn
-
--@deffnx Command suchthat var exp
-+@deffn Command suchthat var exp
-
- If an expression rather than an equation is given to @code{suchthat}, it
- is as though the equation @code{@var{exp}=0} was given.
-@@ -688,8 +689,9 @@
- e2: ---------
- a
- @end example
-+@end deffn
-
--@deffnx Operator | var exp_or_eqn
-+@deffn Operator | var exp_or_eqn
-
- An alternative infix notation is also available for @code{suchthat}.
-
-@@ -857,8 +859,9 @@
-
- Returns the degree of polynomial or equation @var{poly} in variable
- @var{var}.
-+@end deffn
-
--@deffnx Operator degree poly
-+@deffn Operator degree poly
-
- Returns the total-degree, the degree of its highest degree monomial,
- of polynomial or equation @var{poly}.
-@@ -1016,10 +1019,12 @@
- Returns @var{poly1} reduced with respect to @var{poly2} (or @var{eqn})
- and @var{var}. If @var{poly2} is univariate, the third argument is not
- needed.
-+@end deffn
-
--@deffnx Command mod poly1 n
-+@deffn Command mod poly1 n
- Returns @var{poly1} with all the coefficients taken modulo @var{n}.
--@deffnx Command mod poly1
-+@end deffn
-+@deffn Command mod poly1
- Returns @var{poly1} with all the coefficients taken modulo the
- current modulus.
-
-@@ -1220,8 +1225,9 @@
- e1: -1 2 3 5
- @end group
- @end example
-+@end deffn
-
--@deffnx Command factor polyratio
-+@deffn Command factor polyratio
- Given a univariate ratio of polynomials @var{polyratio}, returns a
- matrix of factors and exponents.
-
-@@ -2028,7 +2034,7 @@
- formed from the pair-wise products of components of the inputs. For
- example, for the input tensors @code{x[a,b]} and @code{y[c]}
- @example
--@result{z:tmult(x,y);} z[a,b,c] = x[a,b]*y[c]
-+z:tmult(x,y); @result{} z[a,b,c] = x[a,b]*y[c]
- @end example
-
- With an additional argument, @code{tmult} will produce the inner product
-@@ -2464,8 +2470,9 @@
- If you do not wish to return to Jacal but really want to terminate the
- session and return to the operating system, then after typing
- @code{qed();}, type @code{(slib:exit)} or use @code{quit}.
-+@end deffn
-
--@deffnx Command quit
-+@deffn Command quit
- Exit directly from Jacal to the operating system. You will not be able
- to continue your Jacal session.
-