summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2022-01-21 19:42:24 -0500
committerOleg Pykhalov <go.wigust@gmail.com>2022-01-22 12:01:23 +0300
commitc26cc96da287aab166d30720b59883243db739d3 (patch)
tree169fc3526bdd81523ef27f8b7e2f6c6997b6194c
parent2f51d374b81adb3ad6a6d53632b1b965409a34ce (diff)
downloadguix-patches-c26cc96da287aab166d30720b59883243db739d3.tar
guix-patches-c26cc96da287aab166d30720b59883243db739d3.tar.gz
gnu: scm: Fix build.
* gnu/packages/scheme.scm (scm)[arguments]: Add trailing slashes for library paths in build and post-install phases. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/scheme.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 639896bb85..a5b8192f0a 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2022 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -621,7 +622,7 @@ utility functions for all standard Scheme implementations.")
(replace 'build
(lambda* (#:key inputs outputs #:allow-other-keys)
(setenv "SCHEME_LIBRARY_PATH"
- (search-input-directory inputs "lib/slib"))
+ (search-input-directory inputs "lib/slib/"))
(invoke "make" "scmlit" "CC=gcc")
(invoke "make" "all")))
(add-after 'install 'post-install
@@ -631,7 +632,7 @@ utility functions for all standard Scheme implementations.")
(delete-file req)
(format (open req (logior O_WRONLY O_CREAT))
"(define (library-vicinity) ~s)\n"
- (search-input-directory inputs "lib/slib"))
+ (search-input-directory inputs "lib/slib/"))
;; We must generate the slibcat file.
(invoke (string-append out "/bin/scm")