summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-21 15:09:44 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:22:59 +0100
commit9153e3b87286405cbf9f62de4f0140a900a82184 (patch)
tree4162590bc23e4bfe1a65f792ac70d0f302aec22b
parent69cc97cdfbacf77ec45a8ff480dcc98f4ea33b54 (diff)
downloadguix-patches-9153e3b87286405cbf9f62de4f0140a900a82184.tar
guix-patches-9153e3b87286405cbf9f62de4f0140a900a82184.tar.gz
gnu: python-cython: Add 3.0.0a10.
* gnu/packages/python-xyz.scm (python-cython-3): New variable.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 113e3b8077..f16771173c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5491,6 +5491,21 @@ writing C extensions for Python as easy as Python itself.")
""))
#t)))))))))
+(define-public python-cython-3
+ (package
+ (inherit python-cython)
+ ;; Cython 3 is not officially released yet, so distinguish the name
+ ;; for now.
+ (name "python-cython-next")
+ (version "3.0.0a10")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Cython" version))
+ (sha256
+ (base32
+ "17fqacrpis05w1rpi7d7sbimrk20xf8h6d3vrz5nf6ix3899abil"))))
+ (properties '())))
+
(define-public python-numpy-next
(package
(name "python-numpy-next")