summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-21 22:19:26 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:23:00 +0100
commit4f6cbc0aeee90453d39398a74730879ce16a2e7e (patch)
treea0e8d453dcc14820ff812c6d2919eb6022a02fed
parent5ec4129907e9f122265ffe5891530fc2e4326e27 (diff)
downloadguix-patches-4f6cbc0aeee90453d39398a74730879ce16a2e7e.tar
guix-patches-4f6cbc0aeee90453d39398a74730879ce16a2e7e.tar.gz
gnu: python-pandas: Remove old version.
* gnu/packages/python-science.scm (python-pandas-0.25): Remove variable. (python2-pandas): Inherit from PYTHON-PANDAS.
-rw-r--r--gnu/packages/python-science.scm25
1 files changed, 1 insertions, 24 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 1cfc8e5869..1966d72e09 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -412,33 +412,10 @@ doing practical, real world data analysis in Python.")
(properties `((python2-variant . ,(delay python2-pandas))))
(license license:bsd-3)))
-(define-public python-pandas-0.25
- (package
- (inherit python-pandas)
- (version "0.25.3")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "pandas" version))
- (sha256
- (base32
- "191048m6kdc6yfvqs9w412lq60cfvigrsb57y0x116lwibgp9njj"))))
- (arguments
- (substitute-keyword-arguments (package-arguments python-pandas)
- ((#:phases phases)
- `(modify-phases ,phases
- (replace 'patch-which
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((which (assoc-ref inputs "which")))
- (substitute* "pandas/io/clipboard/__init__.py"
- (("^CHECK_CMD = .*")
- (string-append "CHECK_CMD = \"" which "\"\n"))))
- #t))
- (delete 'prepare-x)))))))
-
;; Pandas 0.24.x are the last versions that support Python 2.
(define-public python2-pandas
(let ((pandas (package-with-python2
- (strip-python2-variant python-pandas-0.25))))
+ (strip-python2-variant python-pandas))))
(package
(inherit pandas)
(version "0.24.2")