summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:53:44 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:52 +0200
commite68df1408ade09d78235925b565b3b6116481c27 (patch)
tree11fb4938ad413eb17d413c1bd75c53409a1fff8d
parent935784ba3457b0e66f493e724c1e76eb5a4ac531 (diff)
downloadguix-patches-e68df1408ade09d78235925b565b3b6116481c27.tar
guix-patches-e68df1408ade09d78235925b565b3b6116481c27.tar.gz
gnu: Add texlive-generic-atbegshi.
* gnu/packages/tex.scm (texlive-generic-atbegshi): New public variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 08ef375696..81d72ec62b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7282,6 +7282,24 @@ refers to the version of scrbook, scrreprt, scrartcl, scrlttr2 and
typearea (which are the main parts of the bundle).")
(license license:lppl1.3+)))
+(define-public texlive-generic-atbegshi
+ (package
+ (inherit (simple-texlive-package
+ "texlive-generic-atbegshi"
+ '("/doc/latex/atbegshi/"
+ "/tex/generic/atbegshi/")
+ (base32
+ "184fr5kd3wl44ix63lwb3ll7dhiikkyw1czbnzrl4am4rx0zh4d8")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/atbegshi")
+ (synopsis "Execute commands at @code{\\shipout} time")
+ (description
+ "This package is a modern reimplementation of package @code{everyshi},
+providing various commands to be executed before a @code{\\shipout} command.
+It makes use of e-TeX’s facilities if they are available. The package may
+be used either with LaTeX or with plain TeX.")
+ (license license:lppl1.3c+)))
+
(define-public texlive-generic-infwarerr
(package
(inherit (simple-texlive-package