summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:54:27 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:52 +0200
commitd476433d702be285cde6634baa2e003fa7e4b252 (patch)
treef7a90034d6650120f9962c04cca0e72f373be630
parent3e0dc201ec4256ba6b9d8a0e2cc93c81781ab748 (diff)
downloadguix-patches-d476433d702be285cde6634baa2e003fa7e4b252.tar
guix-patches-d476433d702be285cde6634baa2e003fa7e4b252.tar.gz
gnu: Add texlive-generic-bitset.
* gnu/packages/tex.scm (texlive-generic-bitset): New public variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f25dc4ce74..6c5840fc7d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7318,6 +7318,27 @@ be used either with LaTeX or with plain TeX.")
integers that can exceed TeX's number limits.")
(license license:lppl1.3c+)))
+(define-public texlive-generic-bitset
+ (package
+ (inherit (simple-texlive-package
+ "texlive-generic-bitset"
+ '("/doc/latex/bitset/README.md"
+ "/tex/generic/bitset/")
+ (base32
+ "0inj6qpzizvsbxdfsaijnl4iq976kyrnchnm3gc1kc2w389zrn1l")
+ #:trivial? #t))
+ (propagated-inputs
+ `(("texlive-generic-infwarerr" ,texlive-generic-infwarerr)
+ ("texlive-generic-intcalc" ,texlive-generic-intcalc)
+ ("texlive-generic-bigintcalc" ,texlive-generic-bigintcalc)))
+ (home-page "https://www.ctan.org/pkg/bitset")
+ (synopsis "Handle bit-vector datatype")
+ (description
+ "This package defines and implements the data type bit set, a vector
+of bits. The size of the vector may grow dynamically. Individual bits
+can be manipulated.")
+ (license license:lppl1.3c+)))
+
(define-public texlive-generic-infwarerr
(package
(inherit (simple-texlive-package