summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:55:30 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:51 +0200
commitd136754211a9567afe5a3e5a7ef6271f925bdf26 (patch)
treeee3c5e2f8144d3f901e5ed961bfa0373de7a9b4a
parentdf5569d5147b92b9d6a0e878b046b01047ae70d1 (diff)
downloadguix-patches-d136754211a9567afe5a3e5a7ef6271f925bdf26.tar
guix-patches-d136754211a9567afe5a3e5a7ef6271f925bdf26.tar.gz
gnu: Add texlive-generic-infwarerr.
* gnu/packages/tex.scm (texlive-generic-infwarerr): New public variable.
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 32fe356a42..0f4527bcc2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7244,6 +7244,23 @@ refers to the version of scrbook, scrreprt, scrartcl, scrlttr2 and
typearea (which are the main parts of the bundle).")
(license license:lppl1.3+)))
+(define-public texlive-generic-infwarerr
+ (package
+ (inherit (simple-texlive-package
+ "texlive-generic-infwarerr"
+ '("/tex/generic/infwarerr/")
+ (base32
+ "19nlrbfmqbkjrrx9x75s9nd6crg1lzimb2fr3hfblaivj6lx8p4r")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/infwarerr")
+ (synopsis "Information/warning/error macros")
+ (description
+ "This package provides a complete set of macros for information,
+warning and error messages. Under LaTeX, the commands are wrappers for
+the corresponding LaTeX commands; under Plain TeX they are available as
+complete implementations.")
+ (license license:lppl1.3c+)))
+
(define-public texlive-generic-listofitems
(package
(name "texlive-generic-listofitems")