summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:50:27 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:51 +0200
commit25de551c26795b273477c591560ddecf2db683fe (patch)
tree7ef2aa190f9167994d50f044349c3e58696e447a
parent730e7fcb77d7a8c9f1770ba0f407c7306d16e4f5 (diff)
downloadguix-patches-25de551c26795b273477c591560ddecf2db683fe.tar
guix-patches-25de551c26795b273477c591560ddecf2db683fe.tar.gz
gnu: Add texlive-latex-atveryend.
* gnu/packages/tex.scm (texlive-latex-atveryend): New public variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bf2e19c149..d000cdb457 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2792,6 +2792,26 @@ with the required packages, constitutes what every LaTeX distribution should
contain.")
(license license:lppl1.3c+))))
+(define-public texlive-latex-atveryend
+ (package
+ (inherit (simple-texlive-package
+ "texlive-latex-atveryend"
+ '("/doc/latex/atveryend/README.md"
+ "/tex/latex/atveryend/")
+ (base32
+ "1gz5ssxjlqa53a8blsmdk2qjahzc910ldh26xjxfxgqnqb03rqx7")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/atveryend")
+ (synopsis "Hooks at the very end of a document")
+ (description
+ "This LaTeX packages provides two hooks for @code{\\end@{document@}
+that are executed after the hook of @code{\\AtEndDocument}:
+@code{\\AfterLastShipout} can be used for code that is to be executed right
+after the last @code{\\clearpage} before the @file{.aux} file is closed.
+@code{\\AtVeryEndDocument} is used for code after closing and final reading
+of the @file{.aux} file.")
+ (license license:lppl1.3c+)))
+
(define-public texlive-latex-filecontents
(package
(name "texlive-latex-filecontents")