summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-12-18 13:36:52 +0000
committerLudovic Courtès <ludo@gnu.org>2022-01-20 15:28:14 +0100
commit15ae25bd253575aae023fc3632e72e3bc64515ad (patch)
tree18496b6b89375673e59e5797af3fd28912e6b91f
parent9e5cdc4a6c33a650c006ed6ce34d4f6c59b29b79 (diff)
downloadguix-patches-15ae25bd253575aae023fc3632e72e3bc64515ad.tar
guix-patches-15ae25bd253575aae023fc3632e72e3bc64515ad.tar.gz
gnu: dune-uggrid: Update to 2.7.1.
* gnu/packages/maths.scm (dune-uggrid): Update to 2.7.1. [arguments]: Parallelize build-tests phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index da25e70092..6c92020565 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6440,7 +6440,7 @@ This package contains the basic DUNE geometry classes.")
(define-public dune-uggrid
(package
(name "dune-uggrid")
- (version "2.7.0")
+ (version "2.7.1")
(source
(origin
(method git-fetch)
@@ -6450,14 +6450,18 @@ This package contains the basic DUNE geometry classes.")
(file-name (git-file-name name version))
(sha256
(base32
- "192miqgmfj6jwk969gydzpbv9ki7jg5nky3ydnrwa2nq29b5xkh0"))))
+ "11qz52g9d5k96fqik2lyi80xryw174rnny074pj70ardl6zzz83p"))))
(build-system cmake-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'build 'build-tests
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "build_tests" make-flags))))))
+ (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+ (apply invoke "make" "build_tests"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))))
(inputs
(list dune-common))
(native-inputs