summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-02 00:59:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-02 01:20:43 +0100
commitec4892c742ff4e2f00d0fc2595843890ef16afa3 (patch)
tree31f5e97ad3ef934b091cfc43af30c062dee17af9
parent36f18626a9f8e9ba287e0fd3f1d0400345ca5ee7 (diff)
downloadguix-patches-ec4892c742ff4e2f00d0fc2595843890ef16afa3.tar
guix-patches-ec4892c742ff4e2f00d0fc2595843890ef16afa3.tar.gz
gnu: python2-numpy: Do not inherit native-inputs.
* gnu/packages/python-xyz.scm (python2-numpy)[native-inputs]: Do not inherit from Python 3 variant; use only python2-cython, python2-pytest, and gfortran. [arguments]: Add phase 'delete-failing-test.
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b2b50ede05..5fe19acb37 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5358,7 +5358,19 @@ capabilities.")
version "/numpy-" version ".tar.gz"))
(sha256
(base32
- "0lg1cycxzi4rvvrd5zxinpdz0ni792fpx6xjd75z1923zcac8qrb")))))))
+ "0lg1cycxzi4rvvrd5zxinpdz0ni792fpx6xjd75z1923zcac8qrb"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments numpy)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'delete-failing-test
+ (lambda _
+ ;; There's just one failing test here.
+ (delete-file "numpy/linalg/tests/test_linalg.py")))))))
+ (native-inputs
+ `(("python-cython" ,python2-cython)
+ ("python-pytest" ,python2-pytest)
+ ("gfortran" ,gfortran))))))
;; Needed by python-numba, see https://github.com/numba/numba/issues/7176
(define-public python-numpy-1.20