summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2022-01-12 23:27:22 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-21 00:11:47 +0100
commitb37d1e02c4b491c49c8b64d46035424b0dc23c4e (patch)
tree4cce185edb41e89b1bf5521ae3f6f2c09c2f55f7
parent7efc4e6b293687d971cbb85de40c3dc5e7b56e5b (diff)
downloadguix-patches-b37d1e02c4b491c49c8b64d46035424b0dc23c4e.tar
guix-patches-b37d1e02c4b491c49c8b64d46035424b0dc23c4e.tar.gz
gnu: Add rust-matchers-0.1.
* gnu/packages/crates-io.scm (rust-matchers-0.1): New variable. (rust-matchers-0.0): Inherit from above. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 25 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f18fe80db7..c9179cc501 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -30315,22 +30315,21 @@ statement, the first matching branch is the item that gets emitted.")
whether an expression matches a pattern.")
(license license:expat)))
-(define-public rust-matchers-0.0
+(define-public rust-matchers-0.1
(package
(name "rust-matchers")
- (version "0.0.1")
+ (version "0.1.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "matchers" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "1q8ckqmkjqkznvdi9x0z769yz2bmvlqcwx51ad2lpk4mfmgpi6gh"))))
+ (base32 "0n2mbk7lg2vf962c8xwzdq96yrc9i0p8dbmm4wa1nnkcp1dhfqw2"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
+ `(#:skip-build? #t
+ #:cargo-inputs
(("rust-regex-automata" ,rust-regex-automata-0.1))))
(home-page "https://github.com/hawkw/matchers")
(synopsis "Regex matching on character and byte streams")
@@ -30340,6 +30339,25 @@ grammars. It provides the subset of the regex crate that only deals with
matching, not parsing substrings.")
(license license:expat)))
+(define-public rust-matchers-0.0
+ (package
+ (inherit rust-matchers-0.1)
+ (name "rust-matchers")
+ (version "0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "matchers" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1q8ckqmkjqkznvdi9x0z769yz2bmvlqcwx51ad2lpk4mfmgpi6gh"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-regex-automata" ,rust-regex-automata-0.1))))))
+
(define-public rust-matrixcompare-core-0.1
(package
(name "rust-matrixcompare-core")