summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-20 15:53:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-20 16:45:55 +0200
commita3b80bc6fb1bb7d5ab51c53adfa99062e585a28a (patch)
tree7289f78080f9e6743ddb20735825e37c965bdc91
parent80c48a2a93968613621f37e21479538e43f3b3d9 (diff)
downloadguix-patches-a3b80bc6fb1bb7d5ab51c53adfa99062e585a28a.tar
guix-patches-a3b80bc6fb1bb7d5ab51c53adfa99062e585a28a.tar.gz
gnu: python-openid: Honor the #:tests? flag.
* gnu/packages/python-web.scm (python-openid)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1c1f497829..0a3915bacf 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2013, 2014, 2015, 2016, 2020 Andreas Enge <andreas@enge.fr>
@@ -1423,9 +1423,10 @@ is Python’s.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "coverage" "run" "-m"
- "unittest" "openid.test.test_suite"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "coverage" "run" "-m"
+ "unittest" "openid.test.test_suite")))))))
(propagated-inputs
(list python-defusedxml))
(native-inputs