summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 00:34:52 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:14 +0100
commit937c5ff1ce4b125f7797fbaea65121a4308b683f (patch)
tree9cb058239b34a575bd0f73c222fdcfef13ff6bd3
parentb000468b922fba25de25faca487b2c5043e173f5 (diff)
downloadguix-patches-937c5ff1ce4b125f7797fbaea65121a4308b683f.tar
guix-patches-937c5ff1ce4b125f7797fbaea65121a4308b683f.tar.gz
gnu: python-bleach: Update to 4.1.0.
* gnu/packages/python-xyz.scm (python-bleach): Update to 4.1.0. [arguments]: Replace check phase. [propagated-inputs]: Add PYTHON-PACKAGING. [native-inputs]: Remove PYTHON-DATRIE, PYTHON-GENSHI, and PYTHON-LXML. (python2-bleach): Remove variable.
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1f772576e2..ef1cd55d89 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12127,26 +12127,28 @@ systems, as a command line tool, and as a Python library.")
(define-public python-bleach
(package
(name "python-bleach")
- (version "3.1.5")
+ (version "4.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "bleach" version))
(sha256
- (base32 "0jqa8f1ni10cyf4h7sjpf8mbqlcbkyvmsnli77qrxdcxvc7m4k1w"))))
+ (base32 "1nkibazmw1ry4cfxs9qrkkidxdf2z1hh1b20xq1ahqdsgsrxh009"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "pytest" "-vv")))))))
(propagated-inputs
- (list python-webencodings python-six))
+ (list python-packaging python-six python-webencodings))
(native-inputs
- (list python-datrie python-genshi python-lxml python-pytest))
+ (list python-pytest))
(home-page "https://github.com/mozilla/bleach")
(synopsis "Whitelist-based HTML-sanitizing tool")
(description "Bleach is an easy whitelist-based HTML-sanitizing tool.")
(license license:asl2.0)))
-(define-public python2-bleach
- (package-with-python2 python-bleach))
-
(define-public python-entrypoints
(package
(name "python-entrypoints")