summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-08-07 16:26:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-08-08 05:23:36 +0200
commit7fae2063f8e118d50050dc3dde57941414bc2976 (patch)
treef0d788335268f1f92adaea59d03db5450dd2f76c
parent4f4134c26d69349a24aa4bbd525bb9367a951a9a (diff)
downloadguix-patches-7fae2063f8e118d50050dc3dde57941414bc2976.tar
guix-patches-7fae2063f8e118d50050dc3dde57941414bc2976.tar.gz
gnu: sudo: Use ‘modify-phases’ syntax.
* gnu/packages/admin.scm (sudo)[arguments]: Use ‘modify-phases’.
-rw-r--r--gnu/packages/admin.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c4aa108f89..c0e5269f69 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016 Peter Feigl <peter.feigl@nexoid.at>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
-;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
@@ -849,29 +849,29 @@ system administrator.")
;; Avoid non-determinism; see <http://bugs.gnu.org/21918>.
#:parallel-build? #f
- #:phases (alist-cons-before
- 'configure 'pre-configure
- (lambda _
- (substitute* "src/sudo_usage.h.in"
- ;; Do not capture 'configure' arguments since we would
- ;; unduly retain references, and also because the
- ;; CPPFLAGS above would close the string literal
- ;; prematurely.
- (("@CONFIGURE_ARGS@") "\"\""))
- (substitute* (find-files "." "Makefile\\.in")
- (("-o [[:graph:]]+ -g [[:graph:]]+")
- ;; Allow installation as non-root.
- "")
- (("^install: (.*)install-sudoers(.*)" _ before after)
- ;; Don't try to create /etc/sudoers.
- (string-append "install: " before after "\n"))
- (("\\$\\(DESTDIR\\)\\$\\(rundir\\)")
- ;; Don't try to create /run/sudo.
- "$(TMPDIR)/dummy")
- (("\\$\\(DESTDIR\\)\\$\\(vardir\\)")
- ;; Don't try to create /var/db/sudo.
- "$(TMPDIR)/dummy")))
- %standard-phases)
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda _
+ (substitute* "src/sudo_usage.h.in"
+ ;; Do not capture 'configure' arguments since we would
+ ;; unduly retain references, and also because the
+ ;; CPPFLAGS above would close the string literal
+ ;; prematurely.
+ (("@CONFIGURE_ARGS@") "\"\""))
+ (substitute* (find-files "." "Makefile\\.in")
+ (("-o [[:graph:]]+ -g [[:graph:]]+")
+ ;; Allow installation as non-root.
+ "")
+ (("^install: (.*)install-sudoers(.*)" _ before after)
+ ;; Don't try to create /etc/sudoers.
+ (string-append "install: " before after "\n"))
+ (("\\$\\(DESTDIR\\)\\$\\(rundir\\)")
+ ;; Don't try to create /run/sudo.
+ "$(TMPDIR)/dummy")
+ (("\\$\\(DESTDIR\\)\\$\\(vardir\\)")
+ ;; Don't try to create /var/db/sudo.
+ "$(TMPDIR)/dummy")))))
;; XXX: The 'testsudoers' test series expects user 'root' to exist, but
;; the chroot's /etc/passwd doesn't have it. Turn off the tests.