summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-02 23:07:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-02 23:07:26 +0100
commit2a112be09aebb3da15958e58fb677e3fa76e2bd8 (patch)
tree5a04d56531e2722c6370c52b99a79a05c2f83f73
parentd976454c6b65264eb1be6b69852a69fe5f6cf6e1 (diff)
downloadguix-patches-2a112be09aebb3da15958e58fb677e3fa76e2bd8.tar
guix-patches-2a112be09aebb3da15958e58fb677e3fa76e2bd8.tar.gz
gnu: Add r-powerplus.
* gnu/packages/cran.scm (r-powerplus): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 14351e6ae0..7433a561ad 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2713,3 +2713,28 @@ kernel methods that seamlessly handle a mix of continuous, unordered, and
ordered factor data types.")
;; Any version of the GPL.
(license license:gpl3+)))
+
+(define-public r-powerplus
+ (package
+ (name "r-powerplus")
+ (version "3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "powerplus" version))
+ (sha256
+ (base32
+ "0ayp6x34hkzgris4j3zbbs0r23n81bhww3wgfyy630ri4sk6brrn"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-complexplus" ,r-complexplus)
+ ("r-expm" ,r-expm)
+ ("r-mass" ,r-mass)
+ ("r-matrix" ,r-matrix)
+ ("r-phontools" ,r-phontools)))
+ (home-page "http://cran.r-project.org/web/packages/powerplus/")
+ (synopsis "Exponentiation operations")
+ (description
+ "This package provides tools for the computation of matrix and scalar
+exponentiation.")
+ (license license:gpl2)))