summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-14 08:04:20 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-10-13 22:29:42 +0300
commit2485f1725614cab0d15bef3738ad89cf1b6e91a4 (patch)
treee9b7d5f51457d7d7d486284dda3eb39c250db6a1
parentfd82f7ae9b4b008b4fc856a929717a11bf0e2667 (diff)
downloadguix-patches-2485f1725614cab0d15bef3738ad89cf1b6e91a4.tar
guix-patches-2485f1725614cab0d15bef3738ad89cf1b6e91a4.tar.gz
gnu: emacs-ghub: Update to 3.2.0-1.cf0b13a.
* gnu/packages/emacs-xyz.scm (emacs-ghub): Update to 3.2.0-1.cf0b13a. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm62
1 files changed, 32 insertions, 30 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6533682b37..a2e09bead9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -564,39 +564,41 @@ deliver data to mobile and web apps.")
(license license:gpl3+)))
(define-public emacs-ghub
- (package
- (name "emacs-ghub")
- (version "3.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/magit/ghub")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0lp52qygyavddl1lrgsyb6mq7hcf9h89dy2pzya3mb2va49f0vvl"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'install 'make-info
- (lambda _
- (invoke "make" "info"))))))
- (native-inputs
- `(("texinfo" ,texinfo)))
- (propagated-inputs
- `(("dash" ,emacs-dash)
- ("graphql" ,emacs-graphql)
- ("treepy" ,emacs-treepy)))
- (home-page "https://github.com/magit/ghub")
- (synopsis "Emacs client libraries for the APIs of various Git forges")
- (description
- "Ghub provides basic support for using the APIs of various Git forges from
+ ;; We need a newer commit to avoid problems in emacs-forge.
+ (let ((commit "cf0b13aeba4df3798e49c205cac2d8fefd53a137")
+ (revision "1"))
+ (package
+ (name "emacs-ghub")
+ (version (git-version "3.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magit/ghub")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fzayvcysk80vv4q332axcjf80x6gsnpcbl0svmpb017ii6wxhid"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-info
+ (lambda _
+ (invoke "make" "info"))))))
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (propagated-inputs
+ `(("dash" ,emacs-dash)
+ ("treepy" ,emacs-treepy)))
+ (home-page "https://github.com/magit/ghub")
+ (synopsis "Emacs client libraries for the APIs of various Git forges")
+ (description
+ "Ghub provides basic support for using the APIs of various Git forges from
Emacs packages. It supports the REST APIs of Github, Github GraphQL, Gitlab,
Gitea, Gogs and Bitbucket. It abstracts access to API resources using only a
handful of functions that are not resource-specific.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-scribble-mode
(let ((commit "217945d54de5e4bb207033f2116baa28f5c5ecf2")