summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-07-23 11:06:35 +0200
committerFederico Beffa <beffa@fbengineering.ch>2015-08-01 12:37:13 +0200
commit61b9ac53c34ac3ab6f2661e0de50ea0292407267 (patch)
treedd1a99a648c4941177652c39ab4e1518ee5cc030
parentcf9ce01fb3d5f4f036bd36c0cc69fa3a519a6685 (diff)
downloadguix-patches-61b9ac53c34ac3ab6f2661e0de50ea0292407267.tar
guix-patches-61b9ac53c34ac3ab6f2661e0de50ea0292407267.tar.gz
gnu: Add python-mistune.
* gnu/packages/python.scm (python-mistune, python2-mistune): New variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6554abba82..aa4080f23c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4543,3 +4543,31 @@ complexity of Python source code.")
(define-public python2-flake8
(package-with-python2 python-flake8))
+
+(define-public python-mistune
+ (package
+ (name "python-mistune")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/m/mistune/mistune-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "17zqjp9m4d1w3jf2rbbq5xshcw24q1vlcv24gkgfqqyyymajxahx"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-nose" ,python-nose)
+ ("python-cython" ,python-cython)))
+ (home-page "https://github.com/lepture/mistune")
+ (synopsis "Markdown parser in pure Python")
+ (description "This package provides a fast markdown parser in pure
+Python.")
+ (license bsd-3)))
+
+(define-public python2-mistune
+ (package-with-python2 python-mistune))