summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-20 15:25:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-20 15:25:56 +0100
commitd99e42d7f62beab57f1bc2a6aef69b3dd8cd1072 (patch)
treeda9838329fb124e6326c2ee29961f1005cef0917
parent15b509e6545d093909569c716ed05453f1af47cf (diff)
downloadguix-patches-d99e42d7f62beab57f1bc2a6aef69b3dd8cd1072.tar
guix-patches-d99e42d7f62beab57f1bc2a6aef69b3dd8cd1072.tar.gz
gnu: samtools-0.1: Install headers and library.
* gnu/packages/bioinformatics.scm (samtools-0.1)[arguments]: Add build phases 'install-library and 'install-headers.
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 357baa289b..7e28ae8ed1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016, 2018, 2019, 2020 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@@ -6316,6 +6316,11 @@ viewer.")
#:make-flags
(list "LIBCURSES=-lncurses")
,@(substitute-keyword-arguments (package-arguments samtools)
+ ((#:modules _ #f)
+ '((ice-9 ftw)
+ (ice-9 regex)
+ (guix build gnu-build-system)
+ (guix build utils)))
((#:phases phases)
`(modify-phases ,phases
(replace 'install
@@ -6325,6 +6330,18 @@ viewer.")
(mkdir-p bin)
(install-file "samtools" bin)
#t)))
+ (add-after 'install 'install-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((lib (string-append (assoc-ref outputs "out") "/lib")))
+ (install-file "libbam.a" lib))))
+ (add-after 'install 'install-headers
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((include (string-append (assoc-ref outputs "out")
+ "/include/samtools/")))
+ (for-each (lambda (file)
+ (install-file file include))
+ (scandir "." (lambda (name)
+ (string-match "\\.h$" name)))))))
(delete 'patch-tests)
(delete 'configure))))))))