summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2022-01-12 23:27:45 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-21 00:11:57 +0100
commita768ad633b3c552dd47df7fa127e63d235e12fbb (patch)
treebbf7b86c71b6f2f2d66761aa37b4f355c2ea630b
parentd11fe28c939d4fc090309b1173dd4c4eeaaf298b (diff)
downloadguix-patches-a768ad633b3c552dd47df7fa127e63d235e12fbb.tar
guix-patches-a768ad633b3c552dd47df7fa127e63d235e12fbb.tar.gz
gnu: Add rust-chalk-derive-0.75.
* gnu/packages/crates-io.scm (rust-chalk-derive-0.75): New variable. (rust-chalk-derive-0.68): Inherit from above. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 25 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a012f2ad8d..9a580660da 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9227,10 +9227,10 @@ chain, the first matching branch is the item that gets emitted.")
(("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))))
-(define-public rust-chalk-derive-0.68
+(define-public rust-chalk-derive-0.75
(package
(name "rust-chalk-derive")
- (version "0.68.0")
+ (version "0.75.0")
(source
(origin
(method url-fetch)
@@ -9239,7 +9239,7 @@ chain, the first matching branch is the item that gets emitted.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0ss18zx2ddp50mvbwffs5jmmcs7a0pkiq1g62xa7z1bacvkm45ga"))))
+ "0v1i5sb1w2skqg5sjy3gimdglsq0in6mc1zz36qyc99lkrgknknm"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
@@ -9256,6 +9256,28 @@ chain, the first matching branch is the item that gets emitted.")
macros.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-chalk-derive-0.68
+ (package
+ (inherit rust-chalk-derive-0.75)
+ (name "rust-chalk-derive")
+ (version "0.68.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "chalk-derive" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ss18zx2ddp50mvbwffs5jmmcs7a0pkiq1g62xa7z1bacvkm45ga"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1)
+ ("rust-synstructure" ,rust-synstructure-0.12))))))
(define-public rust-chalk-ir-0.68
(package
(name "rust-chalk-ir")