summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-01-19 13:17:45 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2022-01-19 16:26:14 +0100
commitf52c4dc82a1ec4a572e50ea4d56e6f4ab9796978 (patch)
tree77ca41ece12490de04d54b5abcc9b33edaaa9355
parentd2ed9027b17955c3ad29df429898582e402f0ad1 (diff)
downloadguix-patches-f52c4dc82a1ec4a572e50ea4d56e6f4ab9796978.tar
guix-patches-f52c4dc82a1ec4a572e50ea4d56e6f4ab9796978.tar.gz
gnu: Add phos.
* gnu/packages/lisp-xyz.scm (cl-phos, ecl-phos, sbcl-phos): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index dd9b195899..2d774463f6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20289,3 +20289,37 @@ client.")
(define-public ecl-cl-gopher
(sbcl-package->ecl-package sbcl-cl-gopher))
+
+(define-public sbcl-phos
+ (let ((commit "6620b82b091cdfed655e1093ef045dbe518d5474"))
+ (package
+ (name "sbcl-phos")
+ (version (git-version "0.0.1" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/omar-polo/phos")
+ (commit commit)))
+ (file-name (git-file-name "phos" version))
+ (sha256
+ (base32
+ "1zwci86rkbaiix0w2gd5q6nr8v2vv945pkvwp0j240iyzd4hfxr3"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-quri sbcl-cl-ppcre sbcl-trivia sbcl-usocket sbcl-cl+ssl
+ ;; For the experimental GUI:
+ sbcl-nodgui))
+ (native-inputs
+ (list sbcl-clunit2))
+ (home-page "https://github.com/omar-polo/phos")
+ (synopsis "Gemini client library and experimental GUI")
+ (description "This package contains a Gemini client library for Common
+Lisp. A subsystem offers an experimental GUI Gemini client.")
+ (license license:isc))))
+
+(define-public cl-phos
+ (sbcl-package->cl-source-package sbcl-phos))
+
+(define-public ecl-phos
+ (sbcl-package->ecl-package sbcl-phos))