summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2016-01-11 13:26:07 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-01-14 09:05:19 -0500
commitea521b42c219d3dc08bef98cba498e988e76a620 (patch)
tree565ded0d6088aebec77aa0268f6b811243535b70
parente90051808badf801050c0034e5c045fec8aef6d2 (diff)
downloadguix-patches-ea521b42c219d3dc08bef98cba498e988e76a620.tar
guix-patches-ea521b42c219d3dc08bef98cba498e988e76a620.tar.gz
gnu: Add python-vcversioner.
* gnu/packages/python.scm (python-vcversioner, python2-vcversioner): New variables.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5f6ac799df..91629e819d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2197,6 +2197,30 @@ than Python’s urllib2 library.")
(define-public python2-requests
(package-with-python2 python-requests))
+(define-public python-vcversioner
+ (package
+ (name "python-vcversioner")
+ (version "2.14.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vcversioner" version))
+ (sha256
+ (base32
+ "11ivq1bm7v0yb4nsfbv9m7g7lyjn112gbvpjnjz8nv1fx633dm5c"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (synopsis "Python library for version number discovery")
+ (description "Vcversioner is a Python library that inspects tagging
+information in a variety of version control systems in order to discover
+version numbers.")
+ (home-page "https://github.com/habnabit/vcversioner")
+ (license isc)))
+
+(define-public python2-vcversioner
+ (package-with-python2 python-vcversioner))
+
(define-public python-jsonschema
(package
(name "python-jsonschema")