summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-08 17:25:05 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-08 17:25:05 +0100
commite359b665e91bea4f4082f811f9d659ea62fd661b (patch)
tree90f77f47f9095ebbbe3ce93dd8e313c78300c3a2
parent206483fef5272475f7cc57e25be95d6a69bfbe39 (diff)
downloadguix-patches-e359b665e91bea4f4082f811f9d659ea62fd661b.tar
guix-patches-e359b665e91bea4f4082f811f9d659ea62fd661b.tar.gz
gnu: emacs-typit: Update to 0.2.2.
* gnu/packages/emacs-xyz.scm (emacs-typit): Update to 0.2.2.
-rw-r--r--gnu/packages/emacs-xyz.scm45
1 files changed, 21 insertions, 24 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 64a0874596..16e6b1a508 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1242,32 +1242,29 @@ handful of functions that are not resource-specific.")
(license license:gpl3+)))
(define-public emacs-typit
- ;; Last release is from 2017.
- (let ((commit "fa125bf43757737fbcf91958b76c38b440d54b4c")
- (revision "2"))
- (package
- (name "emacs-typit")
- (version (git-version "0.2.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mrkkrp/typit")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1l0qb8gjgsmjjdvxlma7g6fn2z6rj246p2kczrikq8ajg1xh61sr"))))
- (build-system emacs-build-system)
- (arguments
- '(#:include (cons "^dict/" %default-include)))
- (propagated-inputs
- (list emacs-f emacs-mmt))
- (home-page "https://github.com/mrkkrp/typit")
- (synopsis "Typing game for Emacs with two difficulties")
- (description "Emacs Typit is a typing game for Emacs. Words that are
+ (package
+ (name "emacs-typit")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrkkrp/typit")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15m4nfsig8w9hykqy9mzd014pqx4fj9yykiw273bwm384lf3dq6y"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:include (cons "^dict/" %default-include)))
+ (propagated-inputs
+ (list emacs-f emacs-mmt))
+ (home-page "https://github.com/mrkkrp/typit")
+ (synopsis "Typing game for Emacs with two difficulties")
+ (description "Emacs Typit is a typing game for Emacs. Words that are
picked randomly from the most frequent words in language you're practicing,
until time is up.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-scribble-mode
(let ((commit "217945d54de5e4bb207033f2116baa28f5c5ecf2")