summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-26 07:52:04 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:01 +0100
commitdfb93951e3b7308506a6a93336073b5091470ab6 (patch)
tree15319dfffb3f2f3f47d9847e76ef6f8553a7de12
parent39782d3e249fe12f7bc1307ff1d324848cc273e1 (diff)
downloadguix-patches-dfb93951e3b7308506a6a93336073b5091470ab6.tar
guix-patches-dfb93951e3b7308506a6a93336073b5091470ab6.tar.gz
gnu: rtl8821ce-linux-module: Use G-expressions.
* gnu/packages/linux.scm (rtl8821ce-linux-module)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f42f35c5c7..a81a9691ab 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1361,22 +1361,23 @@ and the notification, WiFi, and Bluetooth LED.")
"18ma8a8h1l90dss0k6al7q6plwr57jc9g67p22g9917k1jfbhm97"))))
(build-system linux-module-build-system)
(arguments
- `(#:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "KSRC="
- (assoc-ref %build-inputs "linux-module-builder")
- "/lib/modules/build"))
- #:phases
- (modify-phases %standard-phases
- (replace 'build
- (lambda* (#:key (make-flags '()) (parallel-build? #t)
- #:allow-other-keys)
- (apply invoke "make"
- `(,@(if parallel-build?
- `("-j" ,(number->string (parallel-job-count)))
- '())
- ,@make-flags)))))
- #:tests? #f)) ; no test suite
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "KSRC="
+ (assoc-ref %build-inputs
+ "linux-module-builder")
+ "/lib/modules/build"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'build
+ (lambda* (#:key (make-flags '()) (parallel-build? #t)
+ #:allow-other-keys)
+ (apply invoke "make"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))
+ #:tests? #f)) ; no test suite
(home-page "https://github.com/tomaspinho/rtl8821ce")
(synopsis "Linux driver for Realtek RTL8821CE wireless network adapters")
(description "This is Realtek's RTL8821CE Linux driver for wireless