summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-09 19:10:47 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commitd1deb90b3f9d6cb0d0f68b8bd096db2a5053a464 (patch)
treedbd663c1e4dcbffab209d7a7272daff06d4e725c
parent561bb3cb1af2dd499c8fa38441d15ea6bafa2177 (diff)
downloadguix-patches-d1deb90b3f9d6cb0d0f68b8bd096db2a5053a464.tar
guix-patches-d1deb90b3f9d6cb0d0f68b8bd096db2a5053a464.tar.gz
gnu: Add python-click-threading.
* gnu/packages/python.scm (python-click-threading): New variable.
-rw-r--r--gnu/packages/python.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cd02504ad8..30a6059793 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6742,3 +6742,22 @@ for atomic filesystem operations.")
with python-requests.")
(home-page "https://github.com/sigmavirus24/requests-toolbelt")
(license asl2.0)))
+
+(define-public python-click-threading
+ (package
+ (name "python-click-threading")
+ (version "0.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "click-threading" version))
+ (sha256
+ (base32
+ "0jmrv4334lfxa2ss53c06dafdwqbk1pb3ihd26izn5igw1bm8145"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-click" ,python-click)))
+ (synopsis "Utilities for multithreading in Click")
+ (description "This package provides utilities for multithreading in Click
+applications.")
+ (home-page "https://github.com/click-contrib/click-threading")
+ (license license:expat)))