summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-26 08:02:25 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:02 +0100
commitcfe6b3642028b47ff35e3412077457eff2c765db (patch)
tree8c9a99bff0f894677067b754f7d29af8f8507ad4
parentf780660ab7d39e515801b4cde2172a2a78b777ff (diff)
downloadguix-patches-cfe6b3642028b47ff35e3412077457eff2c765db.tar
guix-patches-cfe6b3642028b47ff35e3412077457eff2c765db.tar.gz
gnu: ddcci-driver-linux: Use G-expressions.
* gnu/packages/linux.scm (ddcci-driver-linux)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 923df79dfb..db7d397f4c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1484,23 +1484,23 @@ graphics card on Optimus laptops.")
(base32 "1lww3mnqhxqzj0qbxzbwbq93v9zw49myp7p9ib873a5izbq8nadi"))))
(build-system linux-module-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (replace 'build
- (lambda args
- (for-each
- (lambda (module)
- (with-directory-excursion module
- (apply (assoc-ref %standard-phases 'build) args)))
- '("ddcci" "ddcci-backlight"))))
- (replace 'install
- (lambda args
- (for-each
- (lambda (module)
- (with-directory-excursion module
- (apply (assoc-ref %standard-phases 'install) args)))
- '("ddcci" "ddcci-backlight")))))))
+ (list #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'build
+ (lambda args
+ (for-each
+ (lambda (module)
+ (with-directory-excursion module
+ (apply (assoc-ref %standard-phases 'build) args)))
+ '("ddcci" "ddcci-backlight"))))
+ (replace 'install
+ (lambda args
+ (for-each
+ (lambda (module)
+ (with-directory-excursion module
+ (apply (assoc-ref %standard-phases 'install) args)))
+ '("ddcci" "ddcci-backlight")))))))
(home-page "https://gitlab.com/ddcci-driver-linux/ddcci-driver-linux")
(synopsis "Pair of Linux kernel drivers for DDC/CI monitors")
(description "This package provides two Linux kernel drivers, ddcci and