summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-12-05 20:29:15 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-12-05 20:33:31 +0100
commitc0cc805e3fbabcbae948b7af0875b9655b01b264 (patch)
tree84fe4cc6b03eaa2012a48ef2a84cd414eba7479a
parent694f485b472028e87841a9d2fbfab5728dcd3789 (diff)
downloadguix-patches-c0cc805e3fbabcbae948b7af0875b9655b01b264.tar
guix-patches-c0cc805e3fbabcbae948b7af0875b9655b01b264.tar.gz
gnu: fuse-exfat: Update to 1.2.5.
* gnu/packages/linux.scm (fuse-exfat): Update to 1.2.5. [native-inputs]: Remove scons build system which is no longer used. [arguments]: Remove. [home-page]: Replace dead Google Code home page.
-rw-r--r--gnu/packages/linux.scm48
1 files changed, 7 insertions, 41 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6d00efefac..724a53a30e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2563,55 +2563,21 @@ is flexible, efficient and uses a modular implementation.")
(define-public fuse-exfat
(package
(name "fuse-exfat")
- (version "1.1.0")
+ (version "1.2.5")
(source (origin
(method url-fetch)
- (uri "https://docs.google.com/uc?export=download&\
-id=0B7CLI-REKbE3VTdaa0EzTkhYdU0")
+ (uri (string-append
+ "https://github.com/relan/exfat/releases/download/v"
+ version "/" name "-" version ".tar.gz"))
(sha256
(base32
- "0glmgwrf0nv09am54i6s35ksbvrywrwc51w6q32mv5by8475530r"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "1i0sh0s6wnm4dqxli3drva871wgbbm57qjf592vnswna9hc6bvim"))))
(build-system gnu-build-system)
(native-inputs
- `(("scons" ,scons)
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("fuse" ,fuse)))
- (arguments
- '(#:tests? #f ;no test suite
-
- ;; XXX: Factorize with 'exfat-utils'.
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'scons-propagate-environment
- (lambda _
- ;; Modify the SConstruct file to arrange for
- ;; environment variables to be propagated.
- (substitute* "SConstruct"
- (("^env = Environment\\(")
- "env = Environment(ENV=os.environ, "))))
- (replace 'build
- (lambda _
- (zero? (system* "scons"))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (man8 (string-append out
- "/share/man/man8")))
- (mkdir-p bin)
- (mkdir-p man8)
- (for-each (lambda (file)
- (copy-file
- file
- (string-append man8 "/"
- (basename file))))
- (find-files "." "\\.8$"))
- (zero? (system* "scons" "install"
- (string-append "DESTDIR="
- bin)))))))))
- (home-page "http://code.google.com/p/exfat/")
+ (home-page "https://github.com/relan/exfat")
(synopsis "Mount exFAT file systems")
(description
"This package provides a FUSE-based file system that provides read and