summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-19 00:13:02 +0100
committerMarius Bakke <marius@gnu.org>2022-01-19 10:05:30 +0100
commit9f529627c82f4f84105b4e7929bf00f012deac37 (patch)
treed979835d1070e438ab043f71584900cf818ab03d
parent7b11fd565cc1799b0ba07c121ce4e40eb772b1c9 (diff)
downloadguix-patches-9f529627c82f4f84105b4e7929bf00f012deac37.tar
guix-patches-9f529627c82f4f84105b4e7929bf00f012deac37.tar.gz
gnu: Add python-roundrobin.
* gnu/packages/python-xyz.scm (python-roundrobin): New public variable.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 223c4533a6..2c76787a54 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26831,6 +26831,24 @@ backport of the @code{dataclasses} module for Python 3.6.")
query Watchman to discover file changes.")
(license license:bsd-3)))
+(define-public python-roundrobin
+ (package
+ (name "python-roundrobin")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "roundrobin" version))
+ (sha256
+ (base32 "1akwhvfyi0120zg2xkhfc6jwfkirz5x90yyvw06bndhaaxwcnc5c"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ;no tests on PyPI and no tags in repo
+ (home-page "https://github.com/linnik/roundrobin")
+ (synopsis "Collection of roundrobin utilities")
+ (description
+ "This package provides a collection of utilities for round-robin
+distribution in Python.")
+ (license license:expat)))
+
(define-public python-helpdev
(package
(name "python-helpdev")