summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAleksandr Vityazev <avityazev@posteo.org>2022-01-19 11:30:54 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-19 14:17:04 +0100
commit873b2eca94cb5da13602abe651c6707fe99ff14b (patch)
tree0adf2da847d69674c4deea79ace1eb6ef5f5166a
parent65424e988d8a0f55385b71eb5c064163096fd213 (diff)
downloadguix-patches-873b2eca94cb5da13602abe651c6707fe99ff14b.tar
guix-patches-873b2eca94cb5da13602abe651c6707fe99ff14b.tar.gz
gnu: emacs-telega-server: Update to 0.8.2-0-5739794d.
* gnu/packages/emacs-xyz.scm (emacs-telega-server): Update to 0.8.2-0-5739794d. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f25481e2e6..267b0b3dfa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -90,7 +90,7 @@
;;; Copyright © 2020 Jonathan Rostran <rostranjj@gmail.com>
;;; Copyright © 2020, 2021 Noah Evans <noah@nevans.me>
;;; Copyright © 2020 Brit Butler <brit@kingcons.io>
-;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2021, 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
@@ -26808,11 +26808,11 @@ other @code{helm-type-file} sources such as @code{helm-locate}.")
(license license:gpl3+)))
(define-public emacs-telega-server
- (let ((commit "b4a5e206bd259f3d7f7633a725b2990704d6a1e8")
- (revision "1"))
+ (let ((commit "5739794d2d0c8a4e7b77c2e37a097e19f80ac9f0")
+ (revision "0"))
(package
(name "emacs-telega-server")
- (version (git-version "0.7.15" revision commit))
+ (version (git-version "0.8.2" revision commit))
(source
(origin
(method git-fetch)
@@ -26820,7 +26820,7 @@ other @code{helm-type-file} sources such as @code{helm-locate}.")
(url "https://github.com/zevlg/telega.el")
(commit commit)))
(sha256
- (base32 "0gr4nmpk175hxmj357bpzaqywbjc6dmmvfxnyzkh884vyzbwdxlc"))
+ (base32 "1am0b2bjjkw7zd0yq39v015a08dcbk43j4d4h8y2q8hj53ryfk5a"))
(file-name (git-file-name "emacs-telega" version))
(patches
(search-patches "emacs-telega-path-placeholder.patch"
@@ -26836,12 +26836,11 @@ other @code{helm-type-file} sources such as @code{helm-locate}.")
(add-before 'configure 'enter-subdirectory
(lambda _ (chdir "server")))
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "run_tests.py"
- (("^(TELEGA_SERVER = ).*$" _all prefix)
- (string-append prefix
- "\"" out "/bin/telega-server\"\n"))))))
+ (lambda _
+ (substitute* "run_tests.py"
+ (("^(TELEGA_SERVER = ).*$" _all prefix)
+ (string-append prefix
+ "\"" #$output "/bin/telega-server\"\n")))))
(delete 'check)
(add-after 'install 'check
(assoc-ref %standard-phases 'check))