summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-11-21 10:02:11 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-14 07:51:44 +1000
commit7c033c4627dbcd1ad5996e332976b2b57a0bbb7d (patch)
tree165ca9c97ab998424633830e32ac0dbd306ee8ca
parent7a2eed3aac1ecd0bdf293e33a234fad58f2e5f9e (diff)
downloadguix-patches-7c033c4627dbcd1ad5996e332976b2b57a0bbb7d.tar
guix-patches-7c033c4627dbcd1ad5996e332976b2b57a0bbb7d.tar.gz
gnu: Add ruby-systemu.
* gnu/packages/ruby.scm (ruby-systemu): New variable.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 577be185f4..dcf2eef35e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2930,3 +2930,31 @@ methods, a @code{Mixin} module for including color methods, a @code{Logger}, a
device.")
(home-page "http://rubyworks.github.io/ansi")
(license license:bsd-2)))
+
+(define-public ruby-systemu
+ (package
+ (name "ruby-systemu")
+ (version "2.6.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "systemu" version))
+ (sha256
+ (base32
+ "0gmkbakhfci5wnmbfx5i54f25j9zsvbw858yg3jjhfs5n4ad1xq1"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-version
+ (lambda _
+ (setenv "VERSION" ,version)
+ #t)))))
+ (synopsis "Capture of stdout/stderr and handling of child processes")
+ (description
+ "Systemu can be used on any platform to return status, stdout, and stderr
+of any command. Unlike other methods like @code{open3} and @code{popen4}
+there is no danger of full pipes or threading issues hanging your process or
+subprocess.")
+ (home-page "https://github.com/ahoward/systemu")
+ (license license:ruby)))