summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-09 20:07:55 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commit6bbbb53eeb3f178efbff72ed0bb279fa02d31a7c (patch)
tree10b3ff644e45af52ee78722c413a13df3064d622
parent5c299bf016b822997c012db988e73fcaef113321 (diff)
downloadguix-patches-6bbbb53eeb3f178efbff72ed0bb279fa02d31a7c.tar
guix-patches-6bbbb53eeb3f178efbff72ed0bb279fa02d31a7c.tar.gz
gnu: Add python-sphinxcontrib-newsfeed.
* gnu/packages/python.scm (python-sphinxcontrib-newsfeed): New variable.
-rw-r--r--gnu/packages/python.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0eb3c85a80..2e10233e5b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6948,3 +6948,23 @@ processes across test runs.")
files for use with Python.")
(home-page "https://github.com/collective/icalendar")
(license bsd-2)))
+
+(define-public python-sphinxcontrib-newsfeed
+ (package
+ (name "python-sphinxcontrib-newsfeed")
+ (version "0.1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinxcontrib-newsfeed" version))
+ (sha256
+ (base32
+ "1d7gam3mn8v4in4p16yn3v10vps7nnaz6ilw99j4klij39dqd37p"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docutils" ,python-docutils)
+ ("python-sphinx" ,python-sphinx)))
+ (synopsis "News Feed extension for Sphinx")
+ (description "Sphinxcontrib-newsfeed is an extension for adding a simple
+Blog, News or Announcements section to a Sphinx website.")
+ (home-page "https://bitbucket.org/prometheus/sphinxcontrib-newsfeed")
+ (license bsd-2)))