summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAleksandr Vityazev <avityazev@posteo.org>2022-01-19 11:30:24 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-19 14:17:04 +0100
commit65424e988d8a0f55385b71eb5c064163096fd213 (patch)
tree0ce9d72c0c9706e115ba232cb56632fa3c031f31
parentb029e5fefcc81d33165db2294cad2eb931cddfa7 (diff)
downloadguix-patches-65424e988d8a0f55385b71eb5c064163096fd213.tar
guix-patches-65424e988d8a0f55385b71eb5c064163096fd213.tar.gz
gnu: tdlib: Update to 1.8.0.
* gnu/packages/emacs-xyz.scm (tdlib): Update to 1.8.0. [arguments]<#:phases>: Remove trailing #T. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/messaging.scm71
1 files changed, 35 insertions, 36 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2fe0d35a10..55d71d9398 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2593,45 +2594,43 @@ replacement.")
(license license:gpl2+)))
(define-public tdlib
- (let ((commit "34ba9b21f365b8d3bdc36808c2d665ca5cd128f6"))
- (package
- (name "tdlib")
- (version "1.7.10")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tdlib/td")
- (commit commit)))
- (sha256
- (base32 "06fbdh1jypz0p1rf6xbpias4kx7xplq9xjd9vz177vwj9icq3wki"))
- (file-name (git-file-name name version))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #t
- #:configure-flags
- (list "-DCMAKE_BUILD_TYPE=Release"
- "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-failing-tests
- (lambda _
- (substitute* "test/CMakeLists.txt"
- ;; The test cases are compiled into a distinct binary
- ;; which uses mtproto.cpp to attempt to connect to
- ;; a remote server. Removing this file from the sources
- ;; list disables those specific test cases.
- (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") ""))
- #t)))))
- (native-inputs
- (list gperf openssl zlib php doxygen))
- (synopsis "Cross-platform library for building Telegram clients")
- (description "Tdlib is a cross-platform library for creating custom
+ (package
+ (name "tdlib")
+ (version "1.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tdlib/td")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "19psqpyh9a2kzfdhgqkirpif4x8pzy89phvi59dq155y30a3661q"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #t
+ #:configure-flags
+ (list "-DCMAKE_BUILD_TYPE=Release"
+ "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests
+ (lambda _
+ (substitute* "test/CMakeLists.txt"
+ ;; The test cases are compiled into a distinct binary
+ ;; which uses mtproto.cpp to attempt to connect to
+ ;; a remote server. Removing this file from the sources
+ ;; list disables those specific test cases.
+ (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") "")))))))
+ (native-inputs
+ (list gperf openssl zlib php doxygen))
+ (synopsis "Cross-platform library for building Telegram clients")
+ (description "Tdlib is a cross-platform library for creating custom
Telegram clients following the official Telegram API. It can be easily used
from almost any programming language with a C-FFI and features first-class
support for high performance Telegram Bot creation.")
- (home-page "https://core.telegram.org/tdlib")
- (license license:boost1.0))))
+ (home-page "https://core.telegram.org/tdlib")
+ (license license:boost1.0)))
(define-public purple-mm-sms
(package