summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-09 19:09:19 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commit561bb3cb1af2dd499c8fa38441d15ea6bafa2177 (patch)
tree0d58002f0d154331300eb60f1ac656ed1732147e
parent5c6eea2ad10838f702fc1bbec2bfe711f0c6286a (diff)
downloadguix-patches-561bb3cb1af2dd499c8fa38441d15ea6bafa2177.tar
guix-patches-561bb3cb1af2dd499c8fa38441d15ea6bafa2177.tar.gz
gnu: Add python-requests-toolbelt.
* gnu/packages/python.scm (python-requests-toolbelt): New variable.
-rw-r--r--gnu/packages/python.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dd9878fa29..cd02504ad8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6723,3 +6723,22 @@ WebSocket usage in Python programs.")
for atomic filesystem operations.")
(home-page "https://github.com/untitaker/python-atomicwrites")
(license license:expat)))
+
+(define-public python-requests-toolbelt
+ (package
+ (name "python-requests-toolbelt")
+ (version "0.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests-toolbelt" version))
+ (sha256
+ (base32
+ "1kbms1s52dhb98vbpaprr15b0ijdbqp500lpfsyjccpd8cjkyngk"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (synopsis "Extensions to python-requests")
+ (description "This is a toolbelt of useful classes and functions to be used
+with python-requests.")
+ (home-page "https://github.com/sigmavirus24/requests-toolbelt")
+ (license asl2.0)))