summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-01-13 09:23:43 +0800
committer宋文武 <iyzsong@gmail.com>2016-01-16 08:18:37 +0800
commit4ecdeef8aed9e0dc0e338c205773f11249dcb238 (patch)
tree29bf9dd3f5aba4f0c00717010a517c8b2fcf8b66
parentc06a3de93a98ba3e5ca67d9fa283e2190ef9fe09 (diff)
downloadguix-patches-4ecdeef8aed9e0dc0e338c205773f11249dcb238.tar
guix-patches-4ecdeef8aed9e0dc0e338c205773f11249dcb238.tar.gz
gnu: Add python-astor.
* gnu/packages/python.scm (python-astor, python2-astor): New variables.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b9de9cc5f5..84e93d9ab3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7009,3 +7009,26 @@ output, progress bar display, and pipes.")
(define-public python2-clint
(package-with-python2 python-clint))
+
+(define-public python-astor
+ (package
+ (name "python-astor")
+ (version "0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "astor" version))
+ (sha256
+ (base32
+ "1fdafq5hkis1fxqlmhw0sn44zp2ar46nxhbc22cvwg7hsd8z5gsa"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/berkerpeksag/astor")
+ (synopsis "Read and write Python ASTs")
+ (description
+ "Astor is designed to allow easy manipulation of Python source via the
+Abstract Syntax Tree.")
+ (license bsd-3)))
+
+(define-public python2-astor
+ (package-with-python2 python-astor))