summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-12-09 11:48:06 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-09 11:57:10 +0100
commit444a79b6fea48b17f8a798075d0b75d049be5a5e (patch)
treea9aa8f54ab924b3f238723d212dd2c23fd150d92
parentfe3b8862cfcc2409532c4b7df3af779ec04c694d (diff)
downloadguix-patches-444a79b6fea48b17f8a798075d0b75d049be5a5e.tar
guix-patches-444a79b6fea48b17f8a798075d0b75d049be5a5e.tar.gz
gnu: Add python-flask-restful-swagger.
* gnu/packages/python.scm (python-flask-restful-swagger, python2-flask-restful-swagger): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f61c646233..b0e23b5c1d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11851,3 +11851,26 @@ database).")
(define-public python2-sadisplay
(package-with-python2 python-sadisplay))
+
+(define-public python-flask-restful-swagger
+ (package
+ (name "python-flask-restful-swagger")
+ (version "0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flask-restful-swagger" version))
+ (sha256
+ (base32
+ "16msl8hd5xjmj833bpy264v98cpl5hkw5bgl5gf5vgndxbv3rm6v"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flask-restful" ,python-flask-restful)))
+ (home-page "https://github.com/rantav/flask-restful-swagger")
+ (synopsis "Extract Swagger specs from Flask-Restful projects")
+ (description "This package lets you extract Swagger API documentation
+specs from your Flask-Restful projects.")
+ (license license:expat)))
+
+(define-public python2-flask-restful-swagger
+ (package-with-python2 python-flask-restful-swagger))