summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-05 01:58:34 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-12 00:27:55 +0100
commit365260f4cd2d284d57df739ed41dc8e023059f00 (patch)
tree8edba851c1be71ef36157f897a19d6ee92124d3e
parent9660c2f158f296dc162fd08d08c770095a102b2a (diff)
downloadguix-patches-365260f4cd2d284d57df739ed41dc8e023059f00.tar
guix-patches-365260f4cd2d284d57df739ed41dc8e023059f00.tar.gz
gnu: Update awscli, python-boto3 and python-botocore.
awscli, botocore and boto3 work together and typically require matching versions. * gnu/packages/python-xyz.scm (python-botocore): Update to 1.22.11. (python-boto3): Update to 1.19.11. [native-inputs]: Add python-pytest. * gnu/packages/python-web.scm (awscli): Update to 1.21.11. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm4
-rw-r--r--gnu/packages/python-xyz.scm16
2 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9e7d4113ab..964a045049 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2876,14 +2876,14 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(package
;; Note: updating awscli typically requires updating botocore as well.
(name "awscli")
- (version "1.18.203")
+ (version "1.21.11")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
(base32
- "128zg24961j8nmnq2dxqg6a7zwh3qgv87cmvclsdqwwih9nigxv9"))))
+ "0fkivwbx4nind5b7l4jhqm5bb9drgqsclcslrg4aggf9rcs4g4s0"))))
(build-system python-build-system)
(arguments
;; FIXME: The 'pypi' release does not contain tests.
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 701ff31990..6d0150811f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13731,14 +13731,14 @@ This software is unmaintained, and new projects should use @code{boto3} instead.
;; are compatible.
(package
(name "python-botocore")
- (version "1.19.22")
+ (version "1.22.11")
(source
(origin
(method url-fetch)
(uri (pypi-uri "botocore" version))
(sha256
(base32
- "0iim86x7c6hqmvd61ygz6x6x9glnsfbnyzv2y67qjdcdx8jpkmw7"))))
+ "1z7g2scyzvfq4yj9b4w911k7802ry1v6lqfnwq12l0ak7ywmsvrh"))))
(build-system python-build-system)
(arguments
;; FIXME: Many tests are failing.
@@ -13759,7 +13759,7 @@ interface to the Amazon Web Services (AWS) API.")
(define-public python-boto3
(package
(name "python-boto3")
- (version "1.16.22")
+ (version "1.19.11")
(home-page "https://github.com/boto/boto3")
(source (origin
(method git-fetch)
@@ -13767,19 +13767,19 @@ interface to the Amazon Web Services (AWS) API.")
(file-name (git-file-name name version))
(sha256
(base32
- "0h20hgl4yfl58g75qhb6ibrdmzn47md3srgar7hask14cjmfhfy3"))))
+ "1wv0ci2z5ywvm63dh4mp64vqyyvkm4qxc8dxv8ncrqiiphpgr9aq"))))
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'delete-network-tests
;; Deleting integration tests because they are trying to connect to AWS.
- (lambda _
- (delete-file-recursively "tests/integration")
- #t)))))
+ (lambda _
+ (delete-file-recursively "tests/integration"))))))
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)
- ("python-mock" ,python-mock)))
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-botocore" ,python-botocore)
("python-jmespath" ,python-jmespath)