summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-19 20:23:03 +0100
committerMarius Bakke <marius@gnu.org>2022-01-19 21:41:13 +0100
commit2ee870d0ab71c16e7c14b6d4f13340fff8d6c69a (patch)
tree9838ce72e9d5e10cddb122fa6baece5a05943e14
parentaf36848fb323f44703cfc49dbd7f88196585e1a8 (diff)
downloadguix-patches-2ee870d0ab71c16e7c14b6d4f13340fff8d6c69a.tar
guix-patches-2ee870d0ab71c16e7c14b6d4f13340fff8d6c69a.tar.gz
gnu: python-fonttools: Fix build failure.
* gnu/packages/python-xyz.scm (python-fonttools-with-tests)[arguments]: Skip tests that cannot run. [native-inputs]: Fix inheritance.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 80c36e3f55..eff1c4259b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10977,9 +10977,20 @@ from an XML-based format.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest"))))))))
- (native-inputs
- (modify-inputs (package-inputs python-fonttools)
+ (invoke "pytest" "-vv"
+ "-k"
+ ;; XXX: These tests need .trm files that are
+ ;; not shipped with the PyPI release.
+ (format #f "not ~a"
+ (string-join
+ '("test_read_fontdimens_mathsy"
+ "test_read_fontdimens_mathex"
+ "test_read_fontdimens_vanilla"
+ "test_read_boundary_char"
+ "fontTools.tfmLib")
+ " and not "))))))))))
+ (native-inputs
+ (modify-inputs (package-native-inputs python-fonttools)
(append python-pytest ;FIXME: indentation is broken
python-brotli
python-fs