summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-26 07:39:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-16 01:00:01 +0100
commit2be5454eadf2a1b107ba5a6db1ad67f856b95167 (patch)
treee1a55ad13dabff5a05b0305baffc883a680ab075
parent2e86059172d901dcb24d29f7a477d2229b02cd6b (diff)
downloadguix-patches-2be5454eadf2a1b107ba5a6db1ad67f856b95167.tar
guix-patches-2be5454eadf2a1b107ba5a6db1ad67f856b95167.tar.gz
gnu: acpi-call-linux-module: Use G-expressions.
* gnu/packages/linux.scm (acpi-call-linux-module)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/linux.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 484d312bba..e6c3334747 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1197,25 +1197,25 @@ It has been modified to remove all non-free binary blobs.")
(base32 "1s7h9y3adyfhw7cjldlfmid79lrwz3vqlvziw9nwd6x5qdj4w9vp"))))
(build-system linux-module-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'install 'patch-shebangs-harder
- ;; The (only) shebangs in examples/ don't justify a reference.
- ;; However, do substitute a more portable one than the original.
- (lambda _
- (substitute* (find-files "examples" ".")
- (("^(#! *)/[^ ]*/" _ shebang)
- (string-append shebang "/usr/bin/env ")))))
- (add-after 'install 'install-documentation
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/" ,name "-" ,version)))
- (for-each (lambda (file)
- (let ((target (string-append doc "/" file)))
- (mkdir-p (dirname target))
- (copy-recursively file target)))
- (list "README.md" "examples"))))))))
+ (list #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'patch-shebangs-harder
+ ;; The (only) shebangs in examples/ don't justify a reference.
+ ;; However, do substitute a slightly more portable one.
+ (lambda _
+ (substitute* (find-files "examples" ".")
+ (("^(#! *)/[^ ]*/" _ shebang)
+ (string-append shebang "/usr/bin/env ")))))
+ (add-after 'install 'install-documentation
+ (lambda _
+ (let* ((doc (string-append #$output "/share/doc/"
+ #$name "-" #$version)))
+ (for-each (lambda (file)
+ (let ((target (string-append doc "/" file)))
+ (mkdir-p (dirname target))
+ (copy-recursively file target)))
+ (list "README.md" "examples"))))))))
(home-page "https://github.com/nix-community/acpi_call")
(synopsis "Linux kernel module to perform ACPI method calls")
(description