summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-29 06:11:33 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commit226d333103dd648b0efa86345da751abb763b6a4 (patch)
tree9baf12cf99b47db563b5e67a4c404c88a93f4bf8
parent6bbbb53eeb3f178efbff72ed0bb279fa02d31a7c (diff)
downloadguix-patches-226d333103dd648b0efa86345da751abb763b6a4.tar
guix-patches-226d333103dd648b0efa86345da751abb763b6a4.tar.gz
gnu: Update python-tzlocal to 1.2.
* gnu/packages/python.scm (python-tzlocal): Update to 1.2. [source]: Use pypi-uri. [arguments]: Remove the custom 'unpack phase. [native-inputs]: Remove unzip, python-setuptools. [propagated-inputs]: Add python-pytz.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 4 insertions, 19 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2e10233e5b..32da247bff 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1014,31 +1014,16 @@ doing practical, real world data analysis in Python.")
(define-public python-tzlocal
(package
(name "python-tzlocal")
- (version "1.1.1")
+ (version "1.2")
(source
(origin
(method url-fetch)
- (uri (string-append "https://pypi.python.org/packages/source/t/"
- "tzlocal/tzlocal-" version ".zip"))
+ (uri (pypi-uri "tzlocal" version))
(sha256
(base32
- "1m3y918c3chf41fwg2bx4w42bqsjzn3dyvvcmwwy13c8gj6zssv9"))))
+ "12wsw2fl3adrqrwghasld57bhqdrzn0crblqrci1p5acd0ni53s3"))))
(build-system python-build-system)
- (native-inputs
- `(("unzip" ,unzip)
- ("python-setuptools" ,python-setuptools)))
- (inputs `(("python-pytz" ,python-pytz)))
- (arguments
- `(#:phases
- (alist-replace
- 'unpack
- (lambda _
- (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip"))
- (source (assoc-ref %build-inputs "source")))
- (and (zero? (system* unzip source))
- (chdir (string-append "tzlocal-" ,version)))))
- %standard-phases)))
+ (propagated-inputs `(("python-pytz" ,python-pytz)))
(home-page "https://github.com/regebro/tzlocal")
(synopsis
"Local timezone information for Python")