summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-12-06 22:43:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-07 14:20:46 +0100
commit1ed21519f7de3931489f45fee0d582a43a563380 (patch)
tree490217fc9952d06b3bc7d091ec2eccfd2e0e1137
parent491f291892b5fa4864d796e95889108da9cbe6eb (diff)
downloadguix-patches-1ed21519f7de3931489f45fee0d582a43a563380.tar
guix-patches-1ed21519f7de3931489f45fee0d582a43a563380.tar.gz
gnu: Add python-sadisplay.
* gnu/packages/python.scm (python-sadisplay, python2-sadisplay): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d624229640..8fe3d36d04 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11825,3 +11825,29 @@ the Flask web framework in Python. It is similar to package
@code{python-flask-restful} but supports the @code{python-swagger}
documentation builder.")
(license license:expat)))
+
+(define-public python-sadisplay
+ (package
+ (name "python-sadisplay")
+ (version "0.4.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sadisplay" version))
+ (sha256
+ (base32
+ "0zqad2fl7q26p090qmqgmxbm6iwgf9zij1w8da1g3wdgjj72ql05"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-sqlalchemy" ,python-sqlalchemy)))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://bitbucket.org/estin/sadisplay")
+ (synopsis "SQLAlchemy schema displayer")
+ (description "This package provides a program to build Entity
+Relationship diagrams from a SQLAlchemy model (or directly from the
+database).")
+ (license license:bsd-3)))
+
+(define-public python2-sadisplay
+ (package-with-python2 python-sadisplay))