summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-29 22:37:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-29 22:37:20 +0200
commit00197d7508ea4124e363a4c672abb7610b65acb2 (patch)
tree5ec8250629db3345928d9ea17694989d93b41261
parent211cebef1b658196bbbf0719c1575fb8947c1ccc (diff)
downloadguix-patches-00197d7508ea4124e363a4c672abb7610b65acb2.tar
guix-patches-00197d7508ea4124e363a4c672abb7610b65acb2.tar.gz
gnu: emacs-shell-command+: Update to 2.3.2.
* gnu/packages/emacs-xyz.scm (emacs-shell-command+): Update to 2.3.2.
-rw-r--r--gnu/packages/emacs-xyz.scm37
1 files changed, 20 insertions, 17 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 557dd8ed9f..543ce6303a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28664,26 +28664,29 @@ rather excellent completion provided by both Bash and Zsh.")
(license license:gpl3+)))
(define-public emacs-shell-command+
- (package
- (name "emacs-shell-command+")
- (version "2.3.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~pkal/shell-command-plus")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1lrwp73klx5cb74i7iiq7r83dy55qxg1ivnrhfyvk8y2l9hfz30v"))))
- (build-system emacs-build-system)
- (home-page "http://elpa.gnu.org/packages/shell-command+.html")
- (synopsis "Extended Emacs @code{shell-command}")
- (description
- "Shell-command+ is a @code{shell-command} substitute that extends the
+ ;; XXX: Upstream did not tag last release. The commit below corresponds to
+ ;; the exact version bump.
+ (let ((commit "bf744c63bbd1e3bbb93407bd32d6da670b23e67e"))
+ (package
+ (name "emacs-shell-command+")
+ (version "2.3.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~pkal/shell-command-plus")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0prlvcryq5ngrzn5f45rkw09wbr99v7nnwps2bjrjc3wvr2rp6h0"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/shell-command+.html")
+ (synopsis "Extended Emacs @code{shell-command}")
+ (description
+ "Shell-command+ is a @code{shell-command} substitute that extends the
regular Emacs command with several features. You can for example count all
the lines in a buffer with @code{> wc -l}, or delete all lower case letters in
the selected region with @code{| tr -d a-z}.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-shell-pop
(let ((commit "4b4394037940a890a313d715d203d9ead2d156a6")