summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-07-10 01:36:50 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-07-10 01:39:07 +0200
commit80506bc6daa1d106e6f836f741eedfa92ad4e4b6 (patch)
treefc95dee0d8213279dd6191b17c854a4cc749b2f8
parentc823b958256ba1db6cf896400fae218e4261266e (diff)
downloadguix-patches-80506bc6daa1d106e6f836f741eedfa92ad4e4b6.tar
guix-patches-80506bc6daa1d106e6f836f741eedfa92ad4e4b6.tar.gz
gnu: python-pyyaml: Fix build.
python-cython is required to generate the C source for the libyaml extension, which is required for the `_yaml' module to work. This in turn lets the `sanity-check' phase succeed. * gnu/packages/python-xyz.scm (python-pyyaml)[inputs]: Add python-cython.
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 69414dbcee..7504e9f205 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3524,7 +3524,8 @@ environments and back.")
"0pm440pmpvgv5rbbnm8hk4qga5a292kvlm1bh3x2nwr8pb5p8xv0"))))
(build-system python-build-system)
(inputs
- `(("libyaml" ,libyaml)))
+ `(("libyaml" ,libyaml)
+ ("python-cython" ,python-cython)))
(home-page "https://pyyaml.org")
(synopsis "YAML parser and emitter for Python")
(description