summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-20 10:23:40 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:39 -0500
commit0be45b28a959ce0909c7f7b1232c3d9f40e87ea4 (patch)
treedc0a8dea9f365739a6329e5f6ae179df2da10dc0
parent0557f781506431581217321e245834955bb05438 (diff)
downloadguix-patches-0be45b28a959ce0909c7f7b1232c3d9f40e87ea4.tar
guix-patches-0be45b28a959ce0909c7f7b1232c3d9f40e87ea4.tar.gz
gnu: python-curio: Disable newly failing 'test_timeout' test.
* gnu/packages/python-xyz.scm (python-prettytable) [phases]{check}: Honor TESTS? and skip the 'test_timeout' test.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d142ef6ae5..bc53c50f84 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11022,11 +11022,16 @@ printing of sub-tables by specifying a row range.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "-k"
- ;; Tries to open an outgoing connection.
- "not test_ssl_outgoing"))))))
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "-k"
+ (string-append
+ ;; Tries to open an outgoing connection.
+ "not test_ssl_outgoing "
+ ;; This test fails since Python 3.9.9 (see:
+ ;; https://github.com/dabeaz/curio/issues/347).
+ "and not test_timeout"))))))))
(native-inputs
(list python-pytest))
(home-page "https://github.com/dabeaz/curio")