summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-01-07 15:22:10 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-19 14:04:48 +0100
commit84d444f153ce0a8f6312d480dc1af7aa0c1f3452 (patch)
treedad7619f0c738cffde30588268442b3b8f3c1f65
parent904e1c1b9db32143082c0e29cac12efa3b88bdc8 (diff)
downloadguix-patches-84d444f153ce0a8f6312d480dc1af7aa0c1f3452.tar
guix-patches-84d444f153ce0a8f6312d480dc1af7aa0c1f3452.tar.gz
gnu: Add rust-aes-0.7.
* gnu/packages/crates-io.scm (rust-aes-0.7): New variable. (rust-aes-0.6): Inherit from above. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 28 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d9f985fe1c..aaa4346659 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1262,8 +1262,35 @@ with Associated Data (AEAD) algorithms.")
(("rust-generic-array" ,rust-generic-array-0.12)
("rust-heapless" ,rust-heapless-0.5))))))
+(define-public rust-aes-0.7
+ (package
+ (name "rust-aes")
+ (version "0.7.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "aes" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1f0sdx2fsa8w3l7xzsyi9ry3shvnnsgc0znh50if9fm95vslg2wy"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-cipher" ,rust-cipher-0.3)
+ ("rust-cpufeatures" ,rust-cpufeatures-0.2)
+ ("rust-ctr" ,rust-ctr-0.8)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.3))))
+ (home-page "https://github.com/RustCrypto/block-ciphers")
+ (synopsis "Facade for AES (Rijndael) block ciphers implementations")
+ (description "This package provides a facade for AES (Rijndael) block
+ciphers implementations.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-aes-0.6
(package
+ (inherit rust-aes-0.7)
(name "rust-aes")
(version "0.6.0")
(source
@@ -1273,19 +1300,13 @@ with Associated Data (AEAD) algorithms.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0q85mw70mgr4glza9y9lrs9nxfa1cdcqzfk6wx0smb3623pr2hw8"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-aes-soft" ,rust-aes-soft-0.6)
("rust-aesni" ,rust-aesni-0.10)
("rust-cipher" ,rust-cipher-0.2))
#:cargo-development-inputs
- (("rust-cipher" ,rust-cipher-0.2))))
- (home-page "https://github.com/RustCrypto/block-ciphers")
- (synopsis "Facade for AES (Rijndael) block ciphers implementations")
- (description "This package provides a facade for AES (Rijndael) block
-ciphers implementations.")
- (license (list license:expat license:asl2.0))))
+ (("rust-cipher" ,rust-cipher-0.2))))))
(define-public rust-aes-0.4
(package