summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-19 13:32:46 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-19 14:04:46 +0100
commit48d1649f57a72a748ba49029452621303bb8e139 (patch)
tree88fa511d96f9308f98bbd9319a257fc3fddfc2d9
parentb08fb5041b153f0da94a5ec14e340e3ba8693328 (diff)
downloadguix-patches-48d1649f57a72a748ba49029452621303bb8e139.tar
guix-patches-48d1649f57a72a748ba49029452621303bb8e139.tar.gz
gnu: Add rust-streebog-0.10.
* gnu/packages/crates-io.scm (rust-streebog-0.10): New variable.
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 26 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 036a971a98..dbf5001f6c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -53382,8 +53382,33 @@ iterated over only by reference rather than by value.")
(license (list license:unlicense
license:expat))))
+(define-public rust-streebog-0.10
+ (package
+ (name "rust-streebog")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "streebog" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1w7sxj3risp0zqm6r4mc73bd3fn3bnlxi4l10gp7661i5asr6ajz"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-digest" ,rust-digest-0.10))
+ #:cargo-development-inputs
+ (("rust-digest" ,rust-digest-0.10)
+ ("rust-hex-literal" ,rust-hex-literal-0.2))))
+ (home-page "https://github.com/RustCrypto/hashes")
+ (synopsis "Streebog (GOST R 34.11-2012) hash function")
+ (description
+ "This package provides a streebog (GOST R 34.11-2012) hash function.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-streebog-0.9
(package
+ (inherit rust-streebog-0.10)
(name "rust-streebog")
(version "0.9.2")
(source
@@ -53395,7 +53420,6 @@ iterated over only by reference rather than by value.")
(sha256
(base32
"0lz7ajfqdqbrnj01m1xc01ch1g0s9391ma36qqkiyf1074d1r8nr"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-block-buffer" ,rust-block-buffer-0.9)
@@ -53403,12 +53427,7 @@ iterated over only by reference rather than by value.")
("rust-opaque-debug" ,rust-opaque-debug-0.3))
#:cargo-development-inputs
(("rust-digest" ,rust-digest-0.9)
- ("rust-hex-literal" ,rust-hex-literal-0.2))))
- (home-page "https://github.com/RustCrypto/hashes")
- (synopsis "Streebog (GOST R 34.11-2012) hash function")
- (description
- "This package provides a streebog (GOST R 34.11-2012) hash function.")
- (license (list license:expat license:asl2.0))))
+ ("rust-hex-literal" ,rust-hex-literal-0.2))))))
(define-public rust-strength-reduce-0.2
(package