summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-01 07:56:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-31 04:54:56 +0200
commit3103101ec91ebb8a9d9d15362211fecc660ab459 (patch)
tree539597c1cd0c6337b42ab1c3432189bc5d57dc8a
parentd840f6b98ad9f2dbfb0c9b28005d5ef8d69892b7 (diff)
downloadguix-patches-3103101ec91ebb8a9d9d15362211fecc660ab459.tar
guix-patches-3103101ec91ebb8a9d9d15362211fecc660ab459.tar.gz
gnu: aalib: Use INVOKE.
* gnu/packages/video.scm (aalib)[arguments]: Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/video.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 03bde3ff61..5f045279a6 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -160,22 +160,22 @@
(let ((out (assoc-ref outputs "out"))
(ncurses (assoc-ref inputs "ncurses")))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--build=" build)
- ;; The ancient config.guess is unable to
- ;; guess the host triplet on mips64el.
- ,@(if (string=? "mips64el-linux"
- (%current-system))
- '("--host=mips64el-unknown-linux-gnu")
- '())
- ;; The same is also true with aarch64.
- ,@(if (string=? "aarch64-linux"
- (%current-system))
- '("--host=aarch64-unknown-linux-gnu")
- '())
- (string-append "--with-ncurses="
- ncurses)))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--build=" build)
+ ;; The ancient config.guess is unable to
+ ;; guess the host triplet on mips64el.
+ ,@(if (string=? "mips64el-linux"
+ (%current-system))
+ '("--host=mips64el-unknown-linux-gnu")
+ '())
+ ;; The same is also true with aarch64.
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '())
+ (string-append "--with-ncurses="
+ ncurses))))))))
(home-page "http://aa-project.sourceforge.net/aalib/")
(synopsis "ASCII-art library")
(description