summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-04-03 22:22:29 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-04-05 14:26:57 +0200
commit17c11ae958e5d444549aa4c7589565c092d2ea82 (patch)
tree044ba30be8aa370310378d645f90efee26538b63
parentb54fc8f54ed77341dd64d983cbcb66cc642acbc2 (diff)
downloadguix-patches-17c11ae958e5d444549aa4c7589565c092d2ea82.tar
guix-patches-17c11ae958e5d444549aa4c7589565c092d2ea82.tar.gz
gnu: Add cl-cpus.
* gnu/packages/lisp-xyz.scm (sbcl-cl-cpus, cl-cpus, ecl-cl-cpus): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f206eec456..718d7c429f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15335,6 +15335,35 @@ line tool @code{df} and get disk space information using @code{statvfs}.")
(define-public cl-diskspace
(sbcl-package->cl-source-package sbcl-cl-diskspace))
+(define-public sbcl-cl-cpus
+ (package
+ (name "sbcl-cl-cpus")
+ (version "0.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muyinliu/cl-cpus")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-cpus" version))
+ (sha256
+ (base32 "0sdaff9hpsx7bpkkkqavmxmrrlc2d61gmqjjgn8xchncng4a0rf8"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cffi" ,sbcl-cffi)))
+ (home-page "https://github.com/muyinliu/cl-cpus")
+ (synopsis "Common Lisp feature to get number of CPUs")
+ (description
+ "This package provides a Common Lisp system which has only one function to
+return the CPU count of the current system.")
+ (license license:isc)))
+
+(define-public ecl-cl-cpus
+ (sbcl-package->ecl-package sbcl-cl-cpus))
+
+(define-public cl-cpus
+ (sbcl-package->cl-source-package sbcl-cl-cpus))
+
(define-public sbcl-fof
(package
(name "sbcl-fof")