summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-20 22:48:34 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:42 -0500
commitd07d0835a98bcc2ea02ba8974e202512778b957e (patch)
tree9c4dfff7295688f74a597cc1be8a149bfb9f29e3
parent2fa2b91d59f0c2eb0b1996d49b50750a0f5e5685 (diff)
downloadguix-patches-d07d0835a98bcc2ea02ba8974e202512778b957e.tar
guix-patches-d07d0835a98bcc2ea02ba8974e202512778b957e.tar.gz
gnu: Add python-pysendfile.
* gnu/packages/python-xyz.scm (python-pysendfile): New variable.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 484f64a7d0..73bc870da9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10503,6 +10503,31 @@ add functionality and customization to your projects with their own plugins.")
(define-public python2-straight-plugin
(package-with-python2 python-straight-plugin))
+(define-public python-pysendfile
+ (package
+ (name "python-pysendfile")
+ (version "2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pysendfile" version))
+ (sha256
+ (base32 "05qf0m32isflln1zjgxlpw0wf469lj86vdwwqyizp1h94x5l22ji"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" "/tmp")
+ (invoke "make" "test")))))))
+ (home-page "https://github.com/giampaolo/pysendfile")
+ (synopsis "Python interface to sendfile(2)")
+ (description "The @{pysendfile} Python library provides an interface to
+the @code{sendfile(2)} system call.")
+ (license license:expat)))
+
(define-public python-fonttools
(package
(name "python-fonttools")