summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-17 16:39:06 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-17 22:24:03 -0500
commitdece47497cc0da5672357b7b37fe15a956a78b01 (patch)
treeeefb7be65f7be7792169dbf7c434f8f8cdc13e62
parent2cac7d328abb84dc00118286e9647d2715539c4d (diff)
downloadguix-patches-dece47497cc0da5672357b7b37fe15a956a78b01.tar
guix-patches-dece47497cc0da5672357b7b37fe15a956a78b01.tar.gz
gnu: Add python-frozenlist.
* gnu/packages/python-web.scm (python-frozenlist): New variable.
-rw-r--r--gnu/packages/python-web.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7fa98b7933..a73f0da35f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018, 2019, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2018, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
@@ -167,6 +167,32 @@ API rules.")
(home-page "https://praw.readthedocs.io/en/latest/")
(license license:bsd-2)))
+(define-public python-frozenlist
+ (package
+ (name "python-frozenlist")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "frozenlist" version))
+ (sha256
+ (base32 "1pkr23by7pk9lsmsh0wiqirpkq3f1f08b0615nbzysn51bk1n838"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "tests")))))))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/aio-libs/frozenlist")
+ (synopsis "List-like data structure for Python")
+ (description "@code{frozenlist.FrozenList} is a list-like structure which
+implements @code{collections.abc.MutableSequence}. It can be made immutable
+by calling @code{FrozenList.freeze}.")
+ (license license:asl2.0)))
+
(define-public python-aiohttp
(package
(name "python-aiohttp")