summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-02-17 20:03:54 -0500
committerDavid Thompson <dthompson2@worcester.edu>2016-02-17 21:21:47 -0500
commit50aaec25caa7761849cd4fcbb2b33aeb7b839357 (patch)
tree4f63c73bd074f4c8fdd9901fa1cf53c25896b528
parent373dfe64a39113c31c87019b023fed7034986b33 (diff)
downloadguix-patches-50aaec25caa7761849cd4fcbb2b33aeb7b839357.tar
guix-patches-50aaec25caa7761849cd4fcbb2b33aeb7b839357.tar.gz
gnu: Add python-mako.
* gnu/packages/python.scm (python-mako, python2-mako): New variables.
-rw-r--r--gnu/packages/python.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3dd38627fd..24af2d8142 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7529,3 +7529,35 @@ available in Django, but is a standalone package.")
(inherit (package-with-python2
(strip-python2-variant python-wtforms)))
(inputs `(("python2-setuptools" ,python2-setuptools)))))
+
+(define-public python-mako
+ (package
+ (name "python-mako")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Mako" version))
+ (sha256
+ (base32
+ "136kcjbs0s98qkx8a418b05dfblqp0kiiqyx8vhx4rarwc7bqi3n"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-markupsafe" ,python-markupsafe)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (home-page "http://www.makotemplates.org/")
+ (synopsis "Templating language for Python")
+ (description "Mako is a templating language for Python that compiles
+templates into Python modules.")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-mako))))))
+
+(define-public python2-mako
+ (let ((base (package-with-python2
+ (strip-python2-variant python-mako))))
+ (package
+ (inherit base)
+ (native-inputs
+ (cons `("python2-setuptools" ,python2-setuptools)
+ (package-native-inputs base))))))