summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVicente Vera Parra <vicentemvp@gmail.com>2015-09-15 14:24:17 -0300
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-21 10:48:26 +0200
commit5b9789a6ff16e0cbe951bed3a3f3dbd96fe706ec (patch)
treea3899bdbfecba474040d6264ec5c71d33b473489
parent834f7ff3c0e3266beb13dde7356420960d9ff074 (diff)
downloadguix-patches-5b9789a6ff16e0cbe951bed3a3f3dbd96fe706ec.tar
guix-patches-5b9789a6ff16e0cbe951bed3a3f3dbd96fe706ec.tar.gz
gnu: Add r-testthat.
* gnu/packages/statistics.scm (r-testthat): New variable.
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index cf172ab58a..53d3e28d27 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -812,3 +812,24 @@ automatically detected. Colors and highlighting can be combined and nested.
New styles can also be created easily. This package was inspired by the
\"chalk\" JavaScript project.")
(license license:expat)))
+
+(define-public r-testthat
+ (package
+ (name "r-testthat")
+ (version "0.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "testthat" version))
+ (sha256
+ (base32
+ "0b3akwcx5mv9dmi8vssbk91hr3yrrdxd2fm6zhr31fnyz8kjx4pw"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)
+ ("r-crayon" ,r-crayon)))
+ (home-page "https://github.com/hadley/testthat")
+ (synopsis "Unit testing for R")
+ (description
+ "This package provides a unit testing system for R designed to be fun,
+flexible and easy to set up.")
+ (license license:expat)))